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Overview

DvdStyler is a DVD menu creation GUI that allows the user to create DVD navigation menus
similar to those found on most commercial DVD's. It leverages various other open source video
rendering programs to produce the final DVD menu navigation system. DVDStyler is an open
source program that has been developed with the Linux operating system and ported to the
Windows environment (see ‘Requirements’ for platform support).

Note - At the time of this writing, the program has been shown to operate well on Windows-2000
and Windows-XP. It does not however do well with Windows-98. The developer(s) are currently
attempting to resolve those issues.

Requirements

Linux distribution — The DVDStyler program requires various support program be installed that
are not provided with this distribution. Please visit the websites of each program distribution for
downloads, documentation, and installation details.

1. wxGTK
a. http://lwww.wxwidgets.org/

2. DvdAuthor
a. http://dvdauthor.sourceforge.net/

3. MJPEG Tools
a. http://mjpeg.sourceforge.net/

4. MPEG toolbox (mpgtx)
a. http://mpgtx.sourceforge.net/

5. Xine multimedia player (optional, for preview)
a. http://xinehqg.de/

6. Totem movie player (optional, for generation of thumbnails)
a. http://www.hadess.net/totem.php3

Windows distribution — No additional libraries are required beyond those provided by the
operating system and the DVDStyler installation program.

License

DVDStyler is free software (http://www.gnu.org/philosophy/free-sw.html) distributed under GNU
General Public License (GPL — http://www.gnu.org/copyleft/gpl.html). Please visit those sites for
details of each agreement.

Installation instructions (Windows 2000 / XP)

DvdStyler is provided with an automatic installation system. You can simply follow the provided
prompts to install the program.

During rendering, you will be prompted to select temporary and final output directories. You can
use the default locations or change to the directories of you choice. This manual uses the
directories described below:

1. Optional - Manually create a temporary directory for rendering.
a. This tutorial uses ‘C:\Program Files\DVDStyler\Temp1’'.
b. Temporary files are automatically deleted after rendering.
c. DVD movie files (AUDIO_TS AND VIDEO_TS) will be written here.
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d. Note — During the rendering process, if you enter this directory manually, and it
does not already exist, the program will create it automatically.

2. Optional - Manually create a final directory for rendered movies.

a. This tutorial uses ‘C:\Program Files\DVDStyler\Temp2’.

b. DVD ‘iso’ image files will be written here.

c. Note — During the rendering process, if you enter this directory manually, and it
does not already exist, the program will create it automatically.

3. Optional - Manually create a log directory for logged messages.

a. This tutorial uses ‘C:\Program Files\DVDStyler\Log\Mylog.txt'.

b. Note - The typical user does not need to create this directory or enter it into the
Configuration -> Settings -> Log File field. It is meant for debugging.

Guide

This tutorial presents the shortest possible path to creating a DVD menu. It is limited to a single
movie clip, a single menu selection, and virtually no modifications to the default selections.

1. Start DVDStyler

2. Select a movie clip by:
a. Click on the ‘Directories’ tab on the left side of the program window.
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b. Navigate-to and highlight the directory that contains your movie clip(s). Anicon
for each clip will be presented in the top-center panel.

c. Drag the desired movie clip (left-click, hold, and drag) onto the project timeline
panel at the bottom of the program window.
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3. Create a menu by:

a. Click the ‘Backgrounds’ tab on the left side of the program window.

b. Right click in the Menu Editing Panel to access its speed menu. Select
properties. From the properties menu select the desired format (PAL or NTSC).
Click ‘OK’ to accept. The Menu Editing Panel will automatically adjust to the
selected format. Note — The default format (PAL or NTSC) may be configured in
Configuration -> Settings.

c. Select a menu background image by double-clicking on an image in the
‘Backgrounds’ panel.

Backgro

Buttans

lightblue.jpg  swans.jpg Double-Click to select
a background

d. Note — See ‘Advanced Features / Setting Menu Background Image’ for further
information on background images.

e. Click on the ‘Buttons’ tab on the left-hand edge of the program window.

f. Insert a button by dragging (left-click, hold, and drag) a button name into the
Menu Editing Panel. With the provided handles, re-position the button as
desired.

== [WDSkyler - 0 Movies| DVDSEyler | MySecondoviesoml*

buttonl

Backgrounds - Directories |

Menu editing panel

Buttons

T /ﬁ
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Edit the button properties (name, color, font, etc) by right clicking on the button in
the Menu Editing panel (place the mouse pointer over the button and right-click).
From the speed-menu select ‘Properties’ to access the menu. Change various
properties as desired. When finished, click ‘OK’ to return to the Menu Editing
Panel.

Action: Ijumptitle 1; =]

Text: Ibuttom

Fant: |:| %
Left Right Up Dawn
INDne LI INDne LI INDne LI INDne LI

MNormal  Highlighted  Selected

Text colour: I_J .J ._l
BG colour: &_l &_l &_l

oK | Cancel

4. Save the project

a.

A very basic menu has now been configured. Now is a good time the save the
project. Save it by selecting ‘File’, ‘Save As’, and select a directory and name for
your saved project.

5. Render the project by:

a.
b.

L0

Select ‘File’ then ‘Burn Dvd...’

From the ‘Burn’ dialogue select an appropriate directory for ‘Temporary
directory:’ Use the directory created during the installation instructions.
DVDStyler will automatically append the ‘DVD’ subdirectory to your selection.
Check the box for ‘create iso image’.

From the ‘Burn’ dialogue select an appropriate directory for ‘Save to:’ Use the
directory created during the installation instructions. DVDStyler will automatically
write the ‘dvd.iso’ image file to your selection.

Click ‘Start’ to render the movie. Several DOS-style windows will open, execute
commands, and close during the rendering process. The final ‘iso’ burn image
file will be written to the directory selected in step D above.

Burn your finished DVD with the desired burning software.

x|
Temp directon: IC:\MDvies‘,D\fDSterr’\Temm\dvd\ _I
= @rewiewy
¥ create isoimage
Sawve to: |C:'\M0vies\DVDSterr’\TempE\dvd.iSD J

I~ burn

Dewvize: |1,D,D
Start [:l Cancel | Reset |
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g. Note — The burn selections are currently supported only in the Linux distribution
of DVDStyler.

Advanced features
Setting menu background color
The menu background may be filled with a solid color of your choice. You can select between a
set of 48 basic colors or create a custom color. See ‘Setting Menu Background Image’ for details
on using an image for the background instead of a solid color.

1. Start DVDStyler -> Click ‘Backgrounds’ tab -> Right-click on ‘Menu Editing Panel’ ->

Select ‘Properties’ -> Click the navigation button next to the ‘Colour’ selection
2. Click on the ‘Basic color’ of your choice or create a custom color.
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Setting menu background image

1. Start DVDStyler -> Click ‘Backgrounds’ tab
a. Double click on an image on the ‘Backgrounds’ tab, or
b. Right-click on ‘Menu Editing Panel’ -> Select ‘Properties’ -> Click on the
‘Background / Image field. Enter the drive, directory, and file name of your
choice.

2. The image you select should be properly sized for the background. It will be
automatically stretched and re-sized to fully fit the menu window. The image will appear
warped if it is not properly sized.

a. PAL-720 X576
b. NTSC - 720 X 480

3. The background image shown below is simply a white background with two red lines.
Additional images can be added on top of this image by dragging them from the
backgrounds panel (then position and resize).
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x]
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—Background
Image: IC.\Mvaes\DVDSlylar’\Manual\\magaS\DvdSty\erm5png ey
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End time: I
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8/18/04 DVDStyler Operator's Manual: Program V. 1.06 Page 6



Configuring ‘Enter’, ‘Up’, ‘Down’, ‘Left’, ‘Right’ button actions

This section describes how to associate the actions of the buttons on the remote control with
buttons displayed on the DVD menu. While the menu is displayed during playback, pressing any
of the remote control buttons will have a specific action on the menu.

For example, highlighting a menu button and pressing the remote control ‘Enter’ button will
normally advance playback to the movie clip associated with the button. Pressing the remote
control ‘Down’ button will advance the highlighted menu selection to the next selection on the
menu. Pressing the ‘Up’ button will advance the highlighted selection to the previous selection,
etc.

Pressing the remote controls’ left, right, up, or down buttons will move the focus on the menu
from one item to the next. While defining these actions can become somewhat confusing, they
can also be simplified to eliminate the confusion. Try to get at least a mental picture of the
navigation before assigning button actions.

Simple remote control button nhavigation

Up
Only ‘Up’ and ‘Down’ remote control button N Richt
actions are defined for each menu selection Let | Movie 1

Crown
Pressing any remote control navigation
button has a pre-defined action. In this
case, only up and down actually do
anything
Example U[_) '
-Operator highlights the ‘Movie 2’ menu Left R|ght
selection Do

-Press ‘Down’ and advance to ‘Movie 3’

-Press ‘Up’ and advances to ‘Movie 1’

-Press ‘Left’ and menu does nothing

Up
i Right
-Press ‘Right’ and menu does nothing Let | Movie 3

Dioisin

Complex remote control button navigation

Each remote control button action is l l
defined for each menu selection Up

Left i Right
Pressing any remote control navigation Movie 1 ¢

button has a pre-defined action. Down

Example
-Operator highlights the ‘Movie 1° menu
selection

Up

Left | Movie 2 [Fd
>

Down

=

-Press ‘Down’ and advance to ‘Movie 2’

-Press ‘Up’ and advances to ‘Movie 3'

-Press ‘Left’ and advances to ‘Movie 3’

-Press ‘Right’ and advances to ‘Movie 2’

Up

Left Movie 3 Right

Down

4%\—
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Define button actions by (this assumes the menu has been created with buttons applied):

Right-click on the desired menu buttons speed menu -> Select properties

x|
Action:  Jiump title 1 M
Teaut: |butt0n
Font: J
Left Right Up Down

INDne LI INDne LI INDne LI INDne LI

Marmal  Highlighted  Selected

Text colour: .J .J .J %
BG colaur: &_I &_l &_l

Ok | Cancel |

Note — Options for each drop-down list will appear as movie clips are added to the timeline. With
a single movie clip on the timeline, no navigation options will be listed (other than ‘None’). With
three movies on the timeline, two options will be available (it would be three, but picking yourself
would be a nonsensical selection).

Action — This defines what will happen when the ‘Enter’ button of the remote control is pressed.
Click the down-arrow control to select a movie clip to advance-to.

Text — This is the text that will be displayed for the button. Enter any alpha-numeric text for the
button name.

Font — Click on the font selection button to modify the ‘Text’ font properties.

Left — This defines the action of the remote control ‘Left’ button. Select a menu selection to
advance-to when the ‘Left’ remote control button is pressed.

Right - This defines the action of the remote control ‘Right’ button. Select a menu selection to
advance-to when the ‘Right’ remote control button is pressed.

Up - This defines the action of the remote control ‘Up’ button. Select a menu selection to
advance-to when the ‘Up’ remote control button is pressed.

Down - This defines the action of the remote control ‘Down’ button. Select a menu selection to
advance-to when the ‘Down’ remote control button is pressed.

Text colour (Normal) — This defines the color of the button’s text while the button is not selected.

Text colour (Highlighted) — This defines the color the button’s text will change to while the button
is selected.

Text colour (Selected) — This defines the color the text will change to when the button is selected
by pressing ‘Enter’ on the remote control. It stays in effect until the buttons ‘Action’ is executed.
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BG Colour (Normal) — This is the background color of the text box while button is not selected.

BG Colour (Highlighted) — This defines the color the text box background will change-to while
button is selected.

BG Colour (Selected) — This defines the color the text box background will change-to when the
button is selected by pressing ‘Enter’ on the remote control. It stays in effect until the buttons
‘Action’ is executed.

Note — If you select a background color and later decide to change it back to transparent, click the
color box next to the color selection button.

Moarmal Highlighted ~ Selected

Text calour |—|:| .J | J
B colour QD e |

Click here to restore ‘Transparent’
background

Note — Buttons may be applied over-top of images. The have the button displayed on top of the
image, insert the image first, and then insert the button (objects are displayed in ‘creation’ order).
If you do it in reverse, the image will be displayed overtop of the button.

Setting-up chapter points

Setting up chapter points in DVDStyler is fairly simple, once you understand the basics of chapter
points. However, assigning chapter points to buttons can become somewhat confusing, partially
because it is done in two separate processes. The following examples use a single menu with
multiple chapter points.

The program automatically provides five default chapter points for each clip that is assigned to
the movie timeline. Access the defaults by: Right click on a movie clip on the timeline -> Select
properties —> View ‘Vob Chapters’ field. The default chapter points are:

0 15:00 30:00 45:00 1:00:00
The first step is to determine where you want the chapter points to fall. If your movie clip was 60

minutes long (1 hour, 00 minutes), the default chapter points would make sense. The sequence
would be (refer to diagrams below):

1. Chapter one start point =0 (O0hours, 00 minutes, 00 seconds)
2. Chapter two start point = 15:00 (00 hours, 15 minutes, 00 seconds)
3. Chapter three start point = 30:00 (00 hours, 30 minutes, 00 seconds)
4. Chapter four start point = 45:00 (00 hours, 45 minutes, 00 seconds)
5. Chapter five - Unused - 1:00:00 (1 hours, 00 minutes, 00 seconds)
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VOB Chapters

x|
‘Yob Chapters: 10‘1 5:00,30:00,45:00,1:00:00
Beginning of i End of
Movie Clip Unused Movie Clip
|
Chapter 1 Chaptar 2 Chapter 3 Chapter 4
%
0:00 15:00 30:00 45:00 60:00

| Time - (Hours . Minutes : Seconds) {(hh:mm ss) =2 |

However, most movies are not this convenient. You need to determine sensible chapter points.
One simple method is to:

1. Determine the length of your movie clip. For this example, assume it is 40 minutes.

2. For a movie clip with four chapters, divide the movie clip length by four (40/4 = 10
minutes per chapter). This will result in four separate and equal chapters that are 10
minutes apart:

Start of chapter one =0 (00:00:00)
Start of chapter two = 10:00 (00:10:00)
Start of chapter three = 20:00  (00:20:00)
Start of chapter four = 30:00 (00:30:00)
e. End of movie clip = 40:00 (Not used)
3. Edit the chapter points to look like:
a. 0,10:00, 20:00, 30:00
b. Note — You can have additional entries in the chapter field, but they will only have
and effect if they are assigned to buttons.

aoop

Most professional DVD productions assert chapter points in various points in the movie clip that
coincide with the content of the movie, but those points do not usually land at convenient ‘N’
minute intervals. You can determine the exact second to assert a chapter by previewing the clip
in a movie editor, but doing so is beyond the scope of this discussion. If you do determine them,
by all means, use them here.

The next step is to create buttons that coincide with the chapter points. In the following example
menu there are five buttons created for each movie clip. The first button is simply for ‘Play
Movie’, which starts at the beginning of the clip and uses no chapters. Each of the ‘Chapter’
buttons has a chapter assigned to it by editing the button properties:

1. Assume that the buttons have already been placed on the menu (similar to the ‘Typical
Single Menu...’ diagram below).
Right click on the button for ‘Chapter 1’ -> select ‘Properties’
Modify the ‘Action’ field to include the chapter point:
a. Jump title 1 Chapter 1;

2.
3.
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Achiar; iiump title 1 chapter 1;

KN

Text: |Chapter 1

Fort; J

4. Repeat steps 2 and 3 for each ‘chapter’ button on the menu, adding the chapter point for
each button:
a. Action field for Chapter 1 button - jump title 1 chapter 1;
b. Action field for Chapter 2 button - jump title 1 chapter 2;
c. Action field for Chapter 3 button - jump title 1 chapter 3;
d. Action field for Chapter 4 button - jump title 1 chapter 4;
e. Note — The default chapter point at ‘1:00:00’ is unused.
5. Repeat steps 2 — 4 for each movie clip on the menu.

Typical Single Menu Setup with Chapters

| Movie1(T=0) | | Movie2(T=0) |
| Chapterﬂ (T=0) | | Chapter+1 (T=0)
| Chapter 2 ?T: 15:00) | | Chapter 2 (+T: 15:00} |
| Chapter 3 (+T = 30:00) | | Chapter 2 (+T: 30:00) |
| Chaper 4 (+T = 45.00) | | Chapter 4 (+T = 45.00) |

The default ¥ OB Chapter points are:

0,15:00,30:00,45:00,1:00:00

iewed through Movie Clip 'Properties’ menu from timeling)

6. Note — After editing the ‘Action’ field and closing the ‘Properties’ menu the field might
appear blank when you reopen the ‘Properties’ menu. This happens only in the Windows
distribution. The Linux distribution properly displays the entry.

Movie Clip Properties
Access movie clip properties by:

1. Right click on any movie clip on the timeline.
2. Select ‘Properties’ from the speed menu.
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“ob Chapters: IEI,‘I 5:00,30:00,45:00,1:00:00

“ob Pause: ||:|

Title Pre conmmands: I j
Title Post commands: | TRE j

] | Cancel | [’\\S

Movie clip properties assign how the clip will play in reference to other clips on the DVD (they are
not the properties of the individual clip). They define actions that will happen before, during, and
after a clip is played. For example, when a user presses a ‘Play Movie’ button, you might want it
to:

Go straight to playing the clip, or

Play a copyright clip before playing the movie, or
Play an introduction to the clip, or

Play anything you care to prior to the movie.

El

Each selection on the menu may invoke an action at various times of the movie clip playing,
which are:

1. Vob Chapters — These are chapter points for the movie clip. Each value represents the
elapsed time into the movie where the movie clip will begin to play.
a. Chapter one would be at Time = 0 = the beginning of the movie; Chapter two
would be at Time = 15:00 = 15 minutes into the movie clip, etc.
b. Each clip that is assigned to the movie timeline receives a default set of chapter
points that are assigned to this field.
c. See ‘Setting-up Chapter Points’ for additional details on creating and assigning
chapter points.
2. Vob Pause — This assigns the delay between playing this clip and the next clip to be
played. This is normally set to zero.
3. Title Pre Commands — This defines actions that may be executed prior to playing the
movie clip.
4. Title Post Commands - This defines actions that may be executed after playing the movie
clip. Typically you would want the playback to proceed to the next clip or automatically
return to the main menu.

Additional notes about the playback flow control:

1. Additional information about playback flow control is available at the DvdAuthor website.
a. http://www.dvdauthor.com/tech01.htm

2. VOB - The VOBs represent the multiplexed audio, video, and sub-picture overlay.

3. PGC = Program chain.

4. Each Program Chain in made up of a pre-command, a group of programs, and a post-
command.

5. VMGM refers to the top level menu. In a multiple menu system, the top-level is the
beginning of the menu tree (usually the first menu you see).
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Program Menu Selections

This section describes each selection of each menu. Some selections are currently not
implemented. See the ‘General Notes, Menu Creation Tips, and Known Issues’ section at the
end of this manual for special tips and instructions.

File
1. New
a. Select ‘File -> New’ to create a new DVD project. Any existing project work
will be prompted for saving before opening a new project.
2. Open
a. Select ‘File -> Open’ to load a saved DVD project.
3. Save
a. Select ‘File -> Save’ to save a project.
b. All project configurations will be saved in an ‘XML’ file that defines movie
clips, chapters, menus, buttons, and various other selections.
c. Note — The project must be named with the ‘Save as’ selection. If it has not
already been saved, the ‘Save as’ dialogue will be presented.
4. Save as
a. Select ‘File -> Save as’ to name and save your DVD project.
b. Navigate to an appropriate directory to save the project and enter a project
file name.
c. The default project file name is ‘dvd.xml’.
5. BurnDVD
a. Select ‘Burn DVD' to render your project.
b. Atleast one clip must be assigned to the project timeline prior to rendering a
project. The burn dialogue will be presented.
x|
Termp directony: IC\MDVies\DVDSty\ef\Temp]\dvd\ _I
= previe
¥ create isoimage
Sawe to: IC.\MUV\es\DVDSterH\TempE\dvd.\su _I
I~ burn
Device ITDﬂi
Start IXI Cancel | Reset |
c. Click the file navigation button (square button to the right of the Temp
directory field) to select an appropriate temporary directory. Temporary
rendering file will be automatically deleted after the final files have been
processed.
d. Create iso image check box
i. Check the ‘create iso image’ box to render the project into a burn-
able DVD image.
ii. Uncheck the ‘create iso image’ box to render the project into discrete
DVD files (AUDIO_TS AND VIDEO_TS directories).
e. Click the file navigation button (square button to the right of the ‘Save to’
field) to select an appropriate final project file location. Your DVD image file
(iso) will be written here.
f.  Note — If you un-check ‘create iso image’, the discrete DVD files will be
written to the ‘Temp directory’ location.
6. Exit
a. Click ‘File -> EXxit’ to exit the DVDStyler program. Any existing project work
will be prompted for saving prior to exiting.
8/18/04 DVDStyler Operator’'s Manual: Program V. 1.06 Page 13



Configuration - > Settings

DVDStyler executes several processes during rendering (converts menu background images into
short jpeg clips, de-multiplexes clips into their elemental streams (audio and video), re-
multiplexes, and various other processes). The program provides access to these setting in order
to customize the finished product to your liking. Although most of the settings are appropriate for
most movies, but you may wish to make modifications to meet your needs.

Note — If you make changes and wish to undo the changes, click the reset button to restore all
setting to their default settings.

1)

2)

3)

4)

5)

6)

7

8)

Language

a) Select the desired language by clicking the down-arrow control at the right-hand side
of the ‘Language’ field.

b) Language selections will be executed after the DVDStyler program has been exited
and re-started.

c) Note — See ‘General Notes, Menu Creation Tips, and Known Issues’ if you
experience difficulty in changing the language selection.

Default menu format

a) Select the desired default menu format (PAL or NTSC) for new menus.

b) When selecting ‘File -> New’ this format will be used to size the menu.

c) PAL (720 X 576) is usually used in European countries.

d) NTSC (720 X 480) is usually used in North America and several other countries.

Log file

a) Enter adrive, directory, and file name to log rendering messages.

b) This tutorial uses ‘C:\Program Files\DVDStyler\Log\Mylog.txt'.

¢) Using the message log is optional. If you do not care to have a message log, make
sure this field is completely blank. This field is meant for debugging.

d) Log file message are currently unsupported.

Jpeg2Mpeg command

a) This is the syntax that DVDStyler uses to pass commands to the ‘jpeg2yuv’
command of dvdauthor. It converts the image(s) used in menu backgrounds into
short Mpeg clips used on the DVD menu.

b) DVDStyler supports jpeg, bmp, png, and various other image formats.

Frame rate PAL
a) This is the frame rate DVDStyler uses when render a project in the PAL video format.
b) The PAL default frame rate is 25 frames per second.

Frame rate NTSC

a) This is the frame rate DVDStyler uses when render a project in the NTSC video
format.

b) The NTSC default frame rate is 29.97 frames per second.

Multiplexing command
a) This is the syntax that DVDStyler uses to pass commands to the ‘mplex’ command of
dvdauthor.

Demultiplexing command
a) This is the syntax that DVDStyler uses to pass commands to the ‘mpgtx’ command of
dvdauthor.
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9) Spumaux command
a) This is the syntax that DVDStyler uses to pass commands to the ‘spumux’ command
of dvdauthor.

10) Dvdauthor command
a) This is the syntax that DVDStyler uses to pass commands to the ‘dvdauthor’
command of dvdauthor.

11) Preview command
a) This command is for future use.

12) Create 1ISO command
a) This is the syntax that DVDStyler uses to pass commands to the ‘mkisofs’ command
of dvdauthor.
b) This syntax is invoked only when the ‘create iso image’ checkbox of the burn menu is
checked (follow File -> Burn dvd... to access the burn menu).

13) Burn command
a) This is the syntax that DVDStyler uses to pass commands to the ‘mkisofs’ command
of dvdauthor.
b) This syntax is invoked only when the ‘create iso image’ checkbox of the burn menu is
un-checked (follow File -> Burn dvd... to access the burn menu).

14) CdrecordProDVD key
a) This is the license key for CdRecordProDvd. DVDStyler uses this program to burn
DVD’s.
b) Burning is currently supported only on the Linux distribution of DVDStyler.

Help -> About

This selection displays the program credits, license, and provides a link to the project home page.

Miscellaneous speed menus and buttons

1) Right mouse click on menu editing panel (in an area where no other objects have been
placed)

a) Grid -> (8 X8 or 16 X 16 or 32 X 32)

i) The grid selection allows the operator to set the ‘snap-to’ grid spacing. Any objects
applied to the menu editing panel will align to other objects automatically. Try to use
the same ‘snap to’ resolution throughout an entire project. Snap-to resolutions are:

i) None — Disables ‘snap-to’ function

iii) 8 X 8 — Applies a fine ‘snap-to’ resolution (moves objects 8 pixels at a time)

iv) 16 X 16 - Applies a medium ‘snap-to’ resolution (moves objects 16 pixels at a time)

v) 32 X 32 - Applies a course ‘snap-to’ resolution (moves objects 32 pixels at a time)

b) Add -> Text
i) Allows the operator to add simple text to the menu.
i) Text entries are not associated with any menu pick-region areas.
iii) Text properties may be adjusted (font and color) by right-clicking on the object and
accessing the object speed menu (properties).
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c) Properties
i) Allows the operator to adjust various settings for the menus rendered mpeg

properties (video format, background, and subtitle properties).

Menu Background

-Set to blue

-Right click on open area
to adjust menu video
properties

buttonl

Butions

-Set to blue

-Right click on button to adjust
button properties

button?2

Text
-Right click on the text box fo
adjust text properties Imi.lges R A s .
- Right :lick on image to adjust image properties

TextTextText---This is My Movie Title---TextTextText

2) Right mouse click on an image, or text box, or button box

a) Delete — Deletes the object.
b) Properties — Allows the operator to adjust properties of the selected object.

3) Right mouse click on movies on timeline

a) Clip name

b) Delete — Deletes the clip from the timeline.

c) Properties — Allows the operator to adjust properties of the selected clip.
i) Vob Chapters
i) Vob pause
iii) Title Pre commands
iv) Title Post commands

4) Quick buttons
a) Quick buttons are duplicate selections (in most cases) of functions found under various

top menu selections that are conveniently located for repetitive actions.

New Open Save Burn
project project  project project

2Z DVDStyler - Untitled®

a Buttons

=

Q

-

Stepped ‘Zoom-Out’ Stepped ‘Zoom-In’
on menu on menu

Set zoom factor
— on menu

Set zoom factor
on menu
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Typical menu navigation map

To be added

General Notes, Menu Creation Tips, and Known Issues

1) Adding images to the background menu - Menu images displayed in the ‘Backgrounds’ panel
come from the ‘Backgrounds’ directory of the DVDStyler installation directory (this manual
uses - C:\Program Files\DVDStyler\backgrounds). Images may be added to the menu by
manually copying graphic files onto that directory. DVDStyler supports most common graphic
formats (jpg, png, bmp, etc).

If you do add images, try to use images that are properly sized for the menu format (PAL —
720 X 576 or NTSC — 720 X 480). DVDStyler will automatically stretch and resize the
selected image to fit the menu background. See ‘Advanced Features -> Creating custom
images for backgrounds and movie selections’ for additional details on creating images.

2) Creating custom images for backgrounds and movie selections - Custom images can be
created with most graphics editors (not included as part of DVDStyler). A simple method of
creating an image is to use MS Powerpoint

a) Start MS Powerpoint -> Click ‘File — New’
b) Delete all tittes and heading to get a blank slide.
¢) Change the slide size.
i) Click File -> Page Setup...
i) Change ‘Slide Sized For’ to ‘Custom’
(1) For PAL menus:
(&) Change ‘Width:’ to 6.25 inches
(b) Change ‘Height:’ to 5 inches
(c) 720/576 = 1.25 and 6.26 / 5 = 1.25 (same aspect ratio)
(2) For NTSC menus:
(a) Change ‘Width:’ to 7.5 inches
(b) Change ‘Height:’ to 5 inches
(c) 720/480=1.5and 7.5/5 = 1.5 (same aspect ratio)
d) Add autoshapes, text, and any other desired objects to the slide.
e) Save the slide to a graphic image by:
i) Click ‘File -> Save As...’
i) From the ‘File Save’ dialogue box navigate to the desired directory
iii) Change ‘Save as type:’ to a graphical image type (bmp, jpg, png, etc).
iv) Enter the desired file name.
v) Click ‘Save -> Current Slide Only’ to save the slide as a graphic file.

3) Background images — DVDStyler supports two types of menu images. One is meant to cover
the entire menu background and have other object placed over-top of it. The second is for
various images to be placed wherever you care to place them. The following example uses:

a) Menu background — White filled image (720 X 480) with two red bars.

b) Movie images — Six images, all sized to 150 X 100 pixels

¢) Image format — Most graphics formats are supported (bmp, jpg, png, etc.)

d) Buttons — Six buttons, one for each movie with text properties modified to suit the button.
e) Menu heading — Text located at bottom of menu display to label the menu.
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4)

5)

6)

7

8)

L

My Carroons

=

My Holiday My inati

My Movies - 2004

f) There are two methods of selecting a menu background
i) Double-click on an image on the ‘Backgrounds’ panel, or
i) Right-click on the menu editing panel -> Select ‘Properties’ -> Select the ‘Image’ field
-> Type-in the full path and filename of the image you wish to use.
iii) If you select a menu background and later wish to remove the image altogether,
right-click on the ‘Menu Editing Panel’ -> Select ‘Properties’ -> Select the ‘Image’ field
-> blank out the field.

Graphic editing - XnView is a convenient graphic editing tool (freeware -
http://www.xnview.com) used for cropping, resizing, and a myriad other manipulations.

Close video files - When rendering a project, make sure you don’t have a previous iteration of
the project open with a DVD viewing program. DVDStyler will stop rendering until those files
are released.

Transparent button - If you select a background color for a menu button and later decide to
change it back to transparent, click the color box next to the color selection button.

Moimal Highlighted S elected

Text colour: I_D ._I ._I
BG colour %D IY_I I?_I

Click here to restore ‘Transparent’
background

Freeware burning software — Visit http://www.cdburnerxp.se/help/english/data-svcd.php for
instructions and downloads of CdBurnerXP-Pro.
Known issues

a) Multiple menus are currently not supported. This feature is planned for a future version.

b) The ‘Burn’ selection from the ‘Burn’ menu is currently supported in the Linux distribution
only. This feature is planned for the Windows distribution in a future version.

c) Atthe time of this writing, the program has been shown to operate well on Windows-2000
and Windows-XP. It does not however do well with Windows-98. The developer(s) are
currently attempting to resolve those issues.

d) You may need to remove single-quotes from each command line under ‘Configuration /
Settings’. The developers believe this issue has been resolved but testing is incomplete.
It seems to work well under Windows 2000.
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e)

)

h)

)

K)

Log directory - This ‘Log’ field (from Configuration -> Setting) is for future use. Logged
messages are currently not supported. If you do enter a file name into this field, it must
be a valid location and file name (i.e. ‘C:\Program Files\DVDStyler\Log\MyLog.txt" will
work, ‘C:\Program Files\DVDStyler\Log\’ will cause an error in the rendering process).

Saving your project — Earlier versions of DVDStyler did not support all ‘Property’ saving
functions when saving the menu project (File -> Save as). The developers believe this
issue has been resolved (testing incomplete) but your may wish to do all menu creation,
editing, and final rendering during the same session.

Custom colors do not stay in the custom color grid after restarting the program. This
issue will be resolved in a future version.

Playing music during menu display is planned for a future version.

Rendered movies might not play properly in WinDvd. Clicking and un-clicking the ‘Zoom’
button seems clear it up.

Having other programs active on the desktop sometimes makes the program-focus of
DVDStyler misbehave (render -> switch to another application -> return to DVDStyler and
render another movie -> focus is not always restored to DVDStyler when rendering
completes). Solve this by minimizing all other programs prior to rendering.

Language selection — In the Windows distribution, some users have experienced a
problem restarting the program after changing the ‘Language’ selection (Configuration ->
Settings -> Language). This can be corrected by deleting the registry key or changing it
to English by editing the registry key value back to ‘en’ (don't include the quote marks).

Registry Key - My Computer\HKEY_CURRENT_USER\Software\DVDStyler\Interface

Caution — Registry editing should be done by experts. Do not attempt to modify it if you
are not familiar with the registry system.

After manually editing the ‘Action’ field of a button’s ‘Properties’ and closing the menu,
the field might appear blank when you reopen the ‘Properties’ menu. This happens only
in the Windows distribution. The Linux distribution displays the entry properly.
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